finally got my sub installed

mschiavoni

Purveyor of fine Kias
1,690
0
36
Elizabeth, PA
i finally got my amp & sub installed in the car, ill take some pics ASAP. i tapped an RCA box into the rear speakers at the b-pillar, ran that to the trunk, ran the RCA's to the amp, and ran the power wires thru the body panels... it's only a 380W RMS (continuous power) 12" sub, but it absolutely POUNDS!

wish there was a way to show y'all how it sounds...
 

mschiavoni

Purveyor of fine Kias
1,690
0
36
Elizabeth, PA
\\\'Stavi\\\' pid=\\\'4518\\\' dateline=\\\'1268704457\\\' said:
so there are sub outputs in the stock radio correct?
no, i had to tap into the rear speaker wires, and install an RCA box. the RCA box is in the trunk, and the RCA box input wires are tapped into the rear door speaker wires behind the B-Pillar

USE CAUTION INSTALLING A SUBWOOFER!
if your Forte is anything like mine, the rear deck WILL rattle
 

mschiavoni

Purveyor of fine Kias
1,690
0
36
Elizabeth, PA
\'Kenny C\' pid=\'4529\' dateline=\'1268792731\' said:
Use dynamat or something similar.
there\'s no way to get the deck off though, all the bolts are hidden/covered.

i must say, it sounds really good aside from the rattle :cool:
 

Madlock RedKoup

New Member
8
0
1
How did you get the speakers in the back? Im trying to hook up my amp and subwoofers from my old car. I bought a hi low converter thinking this would be simple, but finding I don\'t evenn know where to begin.
 

mschiavoni

Purveyor of fine Kias
1,690
0
36
Elizabeth, PA
just buy an RCA box and tap into the right & left speakers at the b-pillars- the ones behind the seats... youll have to remove the trim, but thats easy... if i get motivated i will take pictures lol. it sounds really complicated but its actually very easy
 

Cuddles

New Member
12
0
1
What sub/amp are you running? I'm looking at a 12-inch Kicker with a Kenwood amp but I'm not sure how much power I want. Rattling isn't a problem since I'll be sealing everything anyway, but I don't want to overdo anything.

EDIT: Also, which side did you run the power down? And did you use vampire clamps to hook into the RCAs?
 

mschiavoni

Purveyor of fine Kias
1,690
0
36
Elizabeth, PA
i just have a 380W RMS Sony Xplod with a 500W RMS Legacy Amp. i just hid everything under the interior trim and it worked really well. and i just spliced an RCA box into the rear speaker wires right behind the B-pillar. my camera's cable is missing, or i'd provide pictures
 

Cuddles

New Member
12
0
1
mschiavoni said:
i just have a 380W RMS Sony Xplod with a 500W RMS Legacy Amp. i just hid everything under the interior trim and it worked really well. and i just spliced an RCA box into the rear speaker wires right behind the B-pillar. my camera's cable is missing, or i'd provide pictures
A line-out converter, right? I was worried that there would be power issues, but from the sounds of it everything will work out.
 

mschiavoni

Purveyor of fine Kias
1,690
0
36
Elizabeth, PA
Cuddles said:
A line-out converter, right? I was worried that there would be power issues, but from the sounds of it everything will work out.
yea I haven't had any power problems yet. only when all interior lights, headlights, etc. are on do I notice anything, and that's not very often. but yea I call it an RCA box, but I spliced it into the rear speaker wires to create the pre-amp, and from there it's a regular install. works real well, and sounds real good too!
 
Top